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¶ In this part you will set up your workspace for 
digitizing.
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Before We Begin

I assume minimal knowledge of geographic 
information science (GISc). I have written this guide 
in an accessible and fun way so that anyone can 
learn to digitize maps! Throughout the guide I will 
highlight important concepts and provide links to 
more resources.

This guide is written for QGIS 3.2.3, an open-source 
desktop GIS software. You can download it for free 
at https://www.qgis.org/en/site/.
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¶ In this part you will set up your workspace for 
digitizing.

§ Georeferencing

Georeferencing is the process of associating a location with an image.
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Starting a QGIS  
Project

§ Georeferencing

¶ In this part you will set up your workspace for digitizing.

1. Open QGIS
2. Under the Project tab, click New
3. To save your project, under the Project tab again,   
 click Save As...
4. Create a folder where you want to save this work and                
name your project (with no spaces), then click Save (keep 
the default filetype *.qgz)

Your project will look something like this. If it’s saved properly, 
the name will appear in the top left corner
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¶ In this part you will add a basemap to your project.

§ Georeferencing

Basemap

Your basemap will serve as a reference map for assigning 
the location to your image. We will use OpenStreetMap, a 
popular free wiki world map. 

1. To add the QuickMapServices QGIS plugin, under the 
Plugins tab, click Manage and Install Plugins
2. Click on All in the side menu and type QuickMapSer-
vices into the search bar at the top of the window
3. Make sure there is a       in the box, then click Close
4. In the Web tab, hover your mouse on the QuickMapSer-
vices item, move your mouse over to OSM, then click the 
OSM Standard option (this loads just the generic Open-
StreetMap, as opposed to a specific one)
5. Save your project!

Your project will look something like this
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Highlight: Projection
§ Georeferencing

Projection is how we take 3-D data from the earth and put 
it on a 2-D map. Think about peeling an orange: is there a 
way to draw something on the orange, lay the peel flat on 
a table, and preserve the original design? 

No way to project data is  flawless, but we can strategically 
pick projections to minimize distortion. There is a lot about 
projection that I am not able to cover in this guide, but I 
would recommend reading about it on your own. 

A Tale of Three Ohios

Mercator North American 
Equidistant Conic

Universal Transverse 
Mercator Zone 17N

Each of these maps looks slightly different, even though 
they’re all of the same place. Map 1 shows the left border 
as an almost vertical line, Map 2 looks tilted and narrow, and 
Map 3 looks almost like a combination of the first two. The 
difference is the projection (labeled below each map). 

Map 1 Map 2 Map 3

8 About map projections: http://desktop.arcgis.com/en/arcmap/10.3/guide-
books/map-projections/about-map-projections.htm
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Set a Projection 
§ Georeferencing

¶ In this part you will set the projection for your            
project. Before doing anything, you need to pick a good           
projection. For the Ohio Project (see Appendic A), we 
use State Plane. Another option is UTM. You’ll need to do 
some research to find your State Plane/UTM zone. I’m do-
ing Champaign County, OH, which is in Ohio State Plane 
South.

1. Under the Project tab, click on Properties
2. Click on CRS (for “coordinate reference system”)
3. In the search bar, type stateplane ohio, which should 
narrow down the options. I’m choosing NAD_1983_HARN_
StatePlane_Ohio_South_FIPS_3402 (make a note of the 
EPSG code)
4. Once the projection name is highlighted, click OK
5. Your basemap should reload and look different
6. Save your project!

Your project should look something like this. If you 
projected it properly, the EPSG code in the bottom 
right corner will be your new one 

State Plane Coordinate System: http://desktop.arcgis.com/en/arcmap/10.3/guide-
books/map-projections/state-plane-coordinate-system.htm
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¶ In this part you will add an image that you want to 
georeference. I’m assuming you already have a particular 
image you want to digitize. If not, you can download the 
Champaign County images from Dropbox at   

https://tinyurl.com/champaign-images.

Adding an Image
§ Georeferencing

1. Add your images(s) to your project folder. Each map 
must be an individual jpeg file, not a pdf
2. Under the Plugins tab, click Manage and Install Plugins
3. With All selected in the side menu, type georeferencer 
into the search bar
4. Make sure there is a        in the box next to Georeferenc-
er GDAL and click Close
5. Under the Raster tab, click Georeferencer...
6. Select            (Open Raster)
7. Choose an image and click Open (I chose union_south)
8. Select the same projection as you selected for your   
project. You can search by name or EPSG code. When 
you’ve highlighted your projection, click OK 

Your project should look something like this
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§ Georeferencing

¶ In this part you will match points on your image to 
points on the basemap.

Choosing Points

This is the part when you actually assign the location to 
your image.  We do this by matching coordinates. It’s       
important to try to match coordinates as close to the four 
corners as possible for maximum accuracy.

1. Minimize your Georeferencer window while you try to 
find your location on the map. I recommend using Google 
Maps to cross-reference. Try to zoom in as close to your 
image’s location as possible. You can search specific county 
and road names to try to narrow it down. 

2. Zoom into your image to find a recognizable                 
intersection and then find that same intersection on your 
basemap (my first choice is Buck Creek and Route 54 in the 
bottom left corner of the image)
3. To choose points, click          (Add Point)

Zoomed in on 
Union South 
precinct

»
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§ Georeferencing

4. With the +, click on your intersection on the image
5. It will prompt you to enter coordinates, but instead click 
the From map canvas option
6. On your basemap, locate the same intersection and 
select it with the +
7. Click OK in the Enter Map Coordinates box
8. In the table at the bottom of your Georeferencer win-
dow you should see your new coordinate listed as well as a 
small red point on both your image and the basemap
9. For my second coordinate, I’m choosing Mechanicsburg 
Catawba Road and Route 56
10. Repeat the process of zooming and selecting for this 
coordinate
11. Aim for five to six points total with four at the corners 
12. Save your project!

Buck Creek 
and Route 54

Buck Creek 
and Route 54

Table of Selected Points
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¶ In this part you will use the points you’ve marked to 
interpolate a location for the image. Exciting!

Generating a Final 
Image

§ Georeferencing

1. In your Georeferencer window, click         (Transforma-
tion Settings) from the bar at the top
Input the following options: 
Transformation type = Linear
Resampling method = Nearest neighbor
Target SRS = same projection as your project (Ohio State 
Plane South for me)
Output raster = (within your project folder) georeferenced/
precinctname_projection.tif
Compression = None
Load in QGIS when done =
2. After you fill these in, click OK
3. Click        (Start Georeferencing)
4. In a second or two you should see your image show up 
on your basemap
5. Save your project!

Image overlaid 
on basemap «
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¶ In this part you will check to make sure your image is in 
the right location on the basemap.

Checking Your Work
§ Georeferencing

We can get a better view of where our image is by setting 
the transparency. 

1. Back in your main QGIS window, go to the Layers  panel 
where your image and basemap should be listed
2. Right click on your georeferenced image layer
3. Select Properties...
4. Select Transparency from the menu
5. Type in a value for Global opacity (40 to 60% tends to 
be good) and click Apply until you find one you like (then 
click OK)
6. Zoom into your image: Are the intersections lining up? 
Does the placement of the map seem like a good fit?
7. If your answer to either of these is no, you may want to 
redo the georeferencing process. Otherwise you’re good 
to go! 

Checking image 
placement»
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Before you move on, georeference all 
of your images! It is not advised to 
vectorize an incomplete area. In this 
case, we would not vectorize a county 
until all of the precincts are 
georeferenced.
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¶ In this part you will set up your workspace for 
digitizing.

§ Vectorizing

Vectorizing is the process of converting an image to a shapefile.
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¶ In this part you will get the data that you will use to 
create your precinct areas.

Getting Data
§ Vectorizing

Typical vectorizing involves manually drawing an outline 
around your georeferenced features. That isn’t feasible with 
such difficult lines to follow in many of our precinct maps. 
Instead we use census blocks to approximate the area   
covered by each of the precincts.

1. Go to https://www.census.gov/cgi-bin/geo/           
shapefiles2010/main 

2. Select Blocks as your layer type and click Submit
3. Select Ohio in the Block (2010) drop-down menu and 
click Submit
4. Select All counties in one state-based file from the 
drop-down menu and click Submit
5. Unzip the folder into a subfolder called data in your 
project folder so that your folder structure looks like this:

 - project
         - QGIS map
         - images
         - data
             - tl_2010_39_tabblock10.shp
             - ...

** If you are digitizing a state other than Ohio, these same 
instructions apply from here on, just substitute your state name!
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¶ In this part you will set up your workspace for vectorizing. 
Follow the instructions below if all of your images are not 
already loaded into your QGIS project. 

Adding Images to 
Your Project

§ Vectorizing

1. Under the Layer tab mouse over Add Layer and select 
Add Raster Layer...
2. In the Data Source Manager window, click the ... button 
to select the files you want to add
3. Select all of your georeferenced images (the ones you 
created that end in .tif) by selecting the first image and 
then holding down shift when you click the last
4. Once they are all selected, click Open, then click Add
5. Save your project!

This is what my project looks like with all of my images loaded
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Census blocks are the building block for all census 
designated geographies. They can be bounded by 
physical features, such as roads or rivers, or invisible 
features like city or school district lines. In urban areas, 
census blocks tend to align with city blocks bounded 
on all four sides by streets. Rural census blocks can be 
up to hundreds of square miles. Census blocks are the 
smallest unit at which most demographic data from the 
decennial census and American Community Survey 
are available. In many states, including Ohio, it is 
mandated that precincts must follow census block 
boundaries unless a specific reason not to is given. This 
regulation validates our method of building up precincts 
from census blocks.

§ Vectorizing

Highlight: Census 
Blocks

census 
block

voting
precinct
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§ Vectorizing

¶ In this part you will add your census block data.

Adding Census 
Block Data

1. Under the Layer tab, mouse over Add Layer and select 
Add Vector Layer...
2. In the Data Source Manager window, click the ... button 
to select the file you want to add
3. Navigate to the data folder that we put the census 
blocks in and select the SHP file (confusingly, two files end 
in .shp so be careful to not choose the XML Document)  

4.   Click Open, then click OK. Your screen should soon be 
covered in little census blocks!
5.   This is a huge file and will slow down your QGIS, so 
let’s filter out just our county of interest. Right click on 
tl_2010_39_tabblock10 in your layers panel and click on 
Open Attribute Table
6.   On Google, look up the 3-digit FIPS code of your   
county of interest. These can usually be found on            
Wikipedia pages 
7.   In the top bar, click        (Select features using an         
expression)



22

8.   In the Expression text box, type “COUNTYFP10” = 
‘your county FIPS code’ (I used ‘021’ for 
Champaign County), then click Select features

9.   The census blocks in your county should be yellow
10. Right click on tl_2010_39_tabblock10, mouse over 
Export, then click Save Features As...
11. Keep the Format as ESRI Shapefile, then click the ... 
next to File name. Navigate to your data  folder and write 
filtered_county as the File name and click Save
12. Change the CRS to your projection and check the box 
next to Save only selected features and Add saved file to 
map (keep other defaults) and click OK
13. Make sure the new layer is only your county, then in 
the Layers panel right click tl_2010_39_tabblock10 and 
click Remove layer...
14. Click on the filtered_county layer and drag it to 
the bottom on the list of image layers but above OSM      
Standard
15. Save your project!

§ Vectorizing

Expression to 
select Champaign 
County

»
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¶ In this part you will select the census blocks that make 
up a precinct. A warning in advance: to me this is the 
most tedious process when digitizing and is prone to  
mistakes, sometimes ones that take a lot of time to fix. Try 
not to get too frustrated, it’s difficult for everyone!

Building a 
Precinct from 
Census Blocks

§ Vectorizing

1. Pick one precinct to vectorize. I chose Union South
2. Click on the image name in the Layers panel and click 
and drag it to the top of the layers list
3. Right click on your image name and click Zoom to Layer
4. Click and drag the filtered_county layer so that it is right 
under your image layer
5. Change the transparency (so you can see the census 
blocks underneath) by right clicking on the layer then click-
ing Properties...
6. In the Layer Properties window, click Transparency in 
the menu and set the Global Opacity to something you 
like, I chose 30%
7. You can also change the color of the census block layer. 
Right click on the layer name and click Properties... then 



24

§ Vectorizing

click Symbology from the menu
8. Click the Simple fill option then change your Fill color 
and Stroke color (I recommend light colors for the fill and 
dark colors for the stroke)
9. Now we are ready to start selecting! Click on the     fil-
tered_county layer in the Layers panel so that the name is 
highlighted (this tells QGIS which layer we want to select 
features from)
10. From the toolbar at the top, click           (Select   Features 
by Polygon). If there’s a similar selection tool, like Select 
Features by Freehand/Radius/..., click the drop-down 
menu to change it to the correct tool
11. Visually figure out where your precinct is (you can     
toggle transparency and layers to help with this), then with 
your blocks layer highlighted and selection tool activated, 
click in one corner of your precinct, as close to the border 
as you can get

clicked point

Union South 
border

cursor dragging 
selection line

12. Repeat the process of clicking at the angles to draw a 
polygon just inside the border of the precinct
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§ Vectorizing

13. Right click when you have drawn the complete polygon
14. Your selected blocks should be highlighted at this 
point, take a moment to admire your work!

Union South selected from census blocks
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¶ In this part you will finalize your census block selection.

Double-Checking 
and Exporting Your 
Selection

§ Vectorizing

1. Without accidentally clicking on your map with the 
selection tool activated (this will undo your selection), 
click        (Zoom In)  then draw a box around one corner of 
your precinct to magnify it
2. From there, click on        (Pan Map) to search along the 
border of the precinct for any missing census blocks (they 
can be quite small, so look carefully!)

Missing census block!

3. To add missing blocks to your selection, switch your 
selection tool to Select Feature(s) in the drop-down menu 
(be careful of any accidental clicking!)
4. Use the Pan Map and Zoom In tools to get to problem 
spots, if you aren’t already there
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§ Vectorizing

5. With your selected tool activated and your census block 
layer highlighted, click on the feature while holding down 
the shift key that you want to add to your selection (if you 
don’t hold down shift it will replace your entire selection)
6. You can deselect blocks with a similar process
7. Continue to pan and zoom until you have fixed all of the 
missing blocks (I recommend checking the entire border 
twice)
8. It’s okay if your precinct borders don’t line up perfectly 
with your census block boundaries, just get them to line up 
as closely as possible
9. When your selection is complete, give yourself a high-
five! Next, right click on filtered_county in the Layers panel, 
mouse over Export, and click Save Features As
10. Click the ... next to File name
11. In your main project folder, create a new folder called 
precincts
12. Save your layer in that new folder with a descriptive 
name (I use precinctname_countyname)
13. Make sure that the CRS is the same as your project’s 
and that Save only selected features and Add saved file to 
map are checked, then click OK
14. You should now see your new precinct layer! You can 
also deselect the census blocks

Exported precinct layer»

You can still see some of 
the georeferenced image
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¶ In this part you will begin vectorizing the rest of the  
precincts and learn some good strategies.

Continuing the 
Vectorizing

§ Vectorizing

1. The next precinct you’ll vectorize will be adjacent to 
the one you just finished (this is to make sure you aren’t       
skipping any blocks along the boundaries that can be hard 
to see). I chose Union North
2. Repeat the process of dragging your layers into a better 
order for vectorizing (I have the Union North image at the 
top, then the new Union South shapefile, then the census 
block shapefile) and set the transparency of the next image

Union North image

Union South 
Shapefile

Census block 
shapefile

3. Using the same process as before, select the polygon 
just within the border of the precinct
4. Toggle the already-vectorized layer to make sure 
that the borders match up and also that you haven’t                          
accidentally selected blocks that have already been          
assigned a precinct
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§ Vectorizing

5. Double-check all of the blocks along the boundary
6. Export this layer using the same process as before
7. Continue vectorizing by choosing adjacent precincts 
until you have each image done

You should vectorize until you have the whole county done, but for the 
purposes of demonstration I’m just going to do this chunk of 
Champaign County.
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¶ In this part you will simplify your multi-part precincts 
into one complete feature.

Dissolving Blocks 
into Precincts

§ Vectorizing

1. Under the Vector tab, mouse over Geoprocessing Tools 
and click Dissolve...
2. At the bottom of the Dissolve window, click Run as 
Batch Process...
3. Under Input layer, click ..., then Select from Open Lay-
ers...
4. Select all of your precinct shapefiles (but not filtered_
county) and click OK
5. Under Dissolved, click ... next to the first row
6. In your main project folder, create a folder called        
dissolved to store your dissolved shapefiles
7. In the File name bar, type just dis_ and save it as either 
a shapefile or GeoPackage (GPKG, the newer and sleeker 
option), then click Save
8. An Autofill settings window will pop up, for Autofill 
mode select ”Fill with parameter values” and for Parameter 
to use select “Input layer” and then click OK
9. Make sure Load layers on completion is checked, then 
click Run in Background
10. Save your project!
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§ Vectorizing

Some wonderfully dissolved precincts!
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¶ In this part you will add relevant data to the attribute 
tables.

Editing Attributes
§ Vectorizing

1. Your layers should all be labeled as Dissolved in your 
Layers panel. To figure out which precinct name goes with 
each of your Dissolved layers, right click on the layer, click 
Properties..., then select the Information tab from the menu
2. The Source field will tell you which precinct layer it 
came from. You can then change the display name by  
clicking on the Source tab and typing a more descriptive 
name in the Layer name field (do this for each Dissolved 
layer)
3. At this point you can turn off your OSM Standard layer
4. Once you’ve done that, right click on one of your       
dissolved layers and click Open Attribute Table
5. Select        (Toggle editing mode), then        (Delete 
field)
6. Hold down ctrl/cmd to select all of your fields except fid 
then click OK
7. Select        (Add field)
8. Type PRECINCT in the Name field, change Type to Text 
(string), and type 255 in the Length field (the maximum 
number of characters), then click OK
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§ Vectorizing

Adding a PRECINCT field

9. In the cell, type the precinct name
10. Repeat this process for COUNTY

This is what your attribute table would look like for Union South 
precinct in Champaign County

11.  Once you’re done with a table, click         (Save Layer 
Edits) and then click        to leave the editing session
12. Edit the attribute table for each of your dissolved layers



34

§ Vectorizing

¶ In this part you will merge your individual precinct 
shapefiles into one shapefile with multiple features.

Merging Precincts

1. Under the Vector tab, mouse over Data Management 
Tools and click on Merge Vector Layers...
2. Click the ... next to Input layers and select your edited 
and dissolved precincts 
3. For Destination CRS, select the same one you have 
been using throughout the project
4. Click the ... next to Merged and choose Save to File...
5. Create a new folder called merged in your 
main project folder and save your new file there as                        
merged_countyname, then click OK
6. Make sure the box next to Open output file after        
running algorithm is checked 
7. Click Run in Background
8. Save your project!  You may 
need to drag your Merged layer 
to the top for it to be visible

Merged 
shapefile! «
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§ Appendix



Ohio Precincts 
Project

§ Appendix

A

The content for this digitzing guide largely comes out of 
our work at the Voting Rights Data Institute (VRDI) at Tufts 
University. VRDI is run by the Metric Geometry and Gerry-
mandering Group (MGGG), a working group that studies 
the applications of geometry and computing to the U.S. 
redistricting process. They produce high quality research, 
open-source tools and research, and expert witnesses to 
combat gerrymandering. 

The three of us (Katie, Katya, and Ruth) co-led the effort to 
create the first open-source precinct shapefile for the state 
of Ohio to study gerrymandering. In total, we digitized over 
450 images with the help of many other people at the insti-
tute. We needed a way to quickly and effectively teach over 
40 people how to digitize well, so we created this guide.

The final product of that project is currently being used by 
groups like Open Elections, The Democratic Party of Ohio, 
ACLU, and MGGG to study voting rights in Ohio. You can 
access the shapefile at the link on mggg.org, as well as 
check out the other projects.
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Links to More   
Resources

§ Appendix

Metric Geometry and Gerrymandering Group
 mggg.org

All About Redistricting
 redistricting.lls.edu/index.php

Georeferencing Topo Sheets and Scanned Maps
 http://www.qgistutorials.com/en/docs/
 georeferencing_basics.html

Georeferencing Aerial Imagery
 https://www.qgistutorials.com/en/docs/advanced_
 georeferencing.html

Public Lab (aerial imagery to practice georeferecing)
 https://publiclab.org/archive#2/15.0/2.8

Code For America (if you want to get involved with other 
civic engagement work)
 https://brigade.codeforamerica.org/

Election Geodata (the largest collection of open-source 
precinct shapefiles)
 https://github.com/nvkelso/election-geodata
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